Posts Tagged

solución

[Solución] “Not all request modules can be enabled” en NetBeans (Java – JSP)

Estos últimos días estoy trabajando con JSP (JavaServer Pages), que como sabréis es una tecnología que mezcla las tecnologías web con Java, todo en la parte servidor. Para ello, me instalé el ya veterano y todoterreno NetBeans IDE sobre mi distribución GNU/Linux basada en Ubuntu. Tarea para nada complicada, basta con tener instalados los requisitos (en mi caso, como voy a trabajar con Java, necesitaré tener  instalado el JDK) y acto seguido descargarlo desde su página oficial y seguir los pasos de la instalación.

El problema viene cuando cierto individuo felizmente  estuvo pulsando repetidamente el botón “Siguiente” sin prestar demasiada atención a lo que el instalador iba preguntando. ¿Adivinad quién? En efecto … 😁

Pues en esas el instalador te pregunta sobre la carpeta donde tenemos instalado el JDK, teniendo el valor por defecto de /usr, con lo que cuando intentamos crear un nuevo proyecto Java o JSP nos indica que los módulos solicitados no se han podido habilitar (Not all request modules can be enabled ), es decir, no encuentra la instalación de JDK.

Para solucionar este pequeño descuido deberemos  editar el archivo de configuración del programa llamado netbeans.conf, normalmenete situado en $HOME/netbeans-8.2/etc

Y cambiar la ruta de la instalación indicada por la nuestra, que normalmente será  /usr/lub/jvm/java-8-oracle

Tras esto, cerramos y volvemos abrir NetBeans IDE para ahora sí, poder crear nuestro proyecto con total normalidad:

Licencia de Creative Commons
Este obra está bajo una licencia de Creative Commons Reconocimiento-NoComercial-CompartirIgual 4.0 Internacional.

“Crear informe en modo diseño” no funciona sobre GNU/Linux (Solución)

Hace ya un par de semanas que en clase estamos manejando LibreOffice Base, siendo ayer cuando nuestro profesor nos mando crear un informe “en modo diseño”. Me puse de inmediato a ello, pero para mi sorpresa, al intentar pulsar sobre el botón, este no respondía. El programa no hacía ninguna mención, ni tan siquiera arrojaba ningún mensaje de error.

Pero mi sorpresa fue mayor al descubrir que a un par más de compañeros que corrían Base sobre Ubuntu tampoco les funcionaba, frente al resto de la clase que sobre Windows realizaban con total normalidad la actividad. De manera que me puse a investigar un poco por la red, y descubrí que el bug ya estaba reportado desde hace años, incluso parecía arrástralo desde OpenOffice, pero más que un bug se trataba de la falta de un paquete. Concretamente del paquete libreoffice libreoffice-report-builder.

De manera que, siguiendo las instrucciones de la misma página, añadiremos los repositorios oficiales de LibreOffice, realizaremos un update e instalaremos.

sudo add-apt-repository ppa:libreoffice/ppa
sudo add-apt-repository ppa:libreoffice/libreoffice-universe
sudo apt-get update
sudo apt-get install libreoffice libreoffice-report-builder

 

Y tras esto y reinicar LibreOffice podremos ya acceder a el editor

Licencia de Creative Commons
Este obra está bajo una licencia de Creative Commons Reconocimiento-NoComercial-CompartirIgual 4.0 Internacional.